import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<!\\d[,.])(?:(0)+\\b|0+(?=[1-9]))";
final String string = "so ow - 00250 = 00000000 ]\n"
+ "12.055 12,005\n"
+ "0012.35 0000.35\n"
+ "0012,35 0000,35\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}