import re
regex = re.compile(r"[^a-zA-Z0-9-]")
test_str = ("my/fancy/thing/test\n"
"three.four/now/i/am/two\n"
"basic/test\n"
"no-slashes\n"
"leave_my_underscores_alone\n"
"hyphens-and/slashes/and_underscores!plus+random~characters\n"
"THE KNIGHTS who say \"Ni!\"")
subst = "-"
result = regex.sub(subst, test_str)
if result:
print(result)