#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*nameservers.*$\n.*addresses:).*$"
Local $sString = "network:" & @CRLF & _
" ethernets:" & @CRLF & _
" enp0s3:" & @CRLF & _
" addresses: [10.10.10.5/24]" & @CRLF & _
" gateway4: 10.10.10.1" & @CRLF & _
" dhcp4: no" & @CRLF & _
" nameservers:" & @CRLF & _
" addresses: [1.1.1.1, 2.2.2.2]" & @CRLF & _
" version: 2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")