// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*nameservers.*$\n.*addresses:).*$").unwrap();
let string = "network:
ethernets:
enp0s3:
addresses: [10.10.10.5/24]
gateway4: 10.10.10.1
dhcp4: no
nameservers:
addresses: [1.1.1.1, 2.2.2.2]
version: 2
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}