#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(((20[012]\d|19\d\d)|(1\d|2[0123]))-((0[0-9])|(1[012]))-((0[1-9])|([12][0-9])|(3[01])))|(((0[1-9])|([12][0-9])|(3[01]))-((0[0-9])|(1[012]))-((20[012]\d|19\d\d)|(1\d|2[0123])))|(((20[012]\d|19\d\d)|(1\d|2[0123]))\/((0[0-9])|(1[012]))\/((0[1-9])|([12][0-9])|(3[01])))|(((0[0-9])|(1[012]))\/((0[1-9])|([12][0-9])|(3[01]))\/((20[012]\d|19\d\d)|(1\d|2[0123])))|(((0[1-9])|([12][0-9])|(3[01]))\/((0[0-9])|(1[012]))\/((20[012]\d|19\d\d)|(1\d|2[0123])))|(((0[1-9])|([12][0-9])|(3[01]))\.((0[0-9])|(1[012]))\.((20[012]\d|19\d\d)|(1\d|2[0123])))|(((20[012]\d|19\d\d)|(1\d|2[0123]))\.((0[0-9])|(1[012]))\.((0[1-9])|([12][0-9])|(3[01])))"
Local $sString = "work:" & @CRLF & _
"2022-01-01" & @CRLF & _
"01-01-2020" & @CRLF & _
"1990/01/01" & @CRLF & _
"12/30/2020" & @CRLF & _
"30/12/2020" & @CRLF & _
"30.12.2020" & @CRLF & _
"2020.12.30" & @CRLF & _
"19-12-30" & @CRLF & _
"30-12-19" & @CRLF & _
"2020/12/30" & @CRLF & _
"12/30/19" & @CRLF & _
"30/12/19" & @CRLF & _
"30.12.19" & @CRLF & _
"19.12.30" & @CRLF & _
"" & @CRLF & _
"not work:" & @CRLF & _
"1022-01-01" & @CRLF & _
"01-15-2020" & @CRLF & _
"2990/01/01" & @CRLF & _
"13/30/2020" & @CRLF & _
"30/13/2020" & @CRLF & _
"30.12.9029" & @CRLF & _
"2020.14.30" & @CRLF & _
"2020.12.33" & @CRLF & _
"19-12-33" & @CRLF & _
"19-13-30" & @CRLF & _
"33-12-19" & @CRLF & _
"30-12-35" & @CRLF & _
"2020/13/30" & @CRLF & _
"2020/12/34" & @CRLF & _
"12/30/29" & @CRLF & _
"30/12/29" & @CRLF & _
"30.12.26" & @CRLF & _
"30.12.30" & @CRLF & _
"13/30/19" & @CRLF & _
"30/13/19" & @CRLF & _
"30.13.19" & @CRLF & _
"19.13.30" & @CRLF & _
"12/33/19" & @CRLF & _
"33/12/19" & @CRLF & _
"33.12.19" & @CRLF & _
"19.12.33" & @CRLF & _
"1/1/19" & @CRLF & _
"1/01/19" & @CRLF & _
"01/1/19" & @CRLF & _
"1/01/2019" & @CRLF & _
"1/1/2019" & @CRLF & _
"01/1/2019" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")