re = /(?<=^(?:[^\/]+\/){2})[^\/]+/
str = 'this/is/some/url'
subst = 'a'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result