use strict;
my $str = 'this/is/some/url
/this/is/some/url';
my $regex = qr/^\/*((?:[^/]+\/){2})[^/]+/mp;
my $subst = '$1a';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";