re = /^\/*((?:[^\/]+\/){2})[^\/]+/m
str = 'this/is/some/url
/this/is/some/url'
subst = '$1a'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result