const regex = /[_\W]([a-df-z])(?![^_\W])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[_\\W]([a-df-z])(?![^_\\W])', 'gm')
const str = `(1)/(2)+p_a*r*e*t*a*v+pi+\\delta+\\sigma
(1)/(2)+a_t*e*j*h*o+ \\Delta
(1)/(2)+p_w
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}