re = /\}? +and +(?![^{]*\})\{?/
str = 'Max and Bob and Merry and {Jack and Co.} and Lisa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end