$re = '/;((?:[a-zA-Z]+ )+)(.*?);/m';
$str = '<pnr>0240978840</pnr>;Amplificator AD8622ARMZ;<upa>1</upa>
<pnr>0273101670</pnr>;Power Management LT1236BIS8-10;<upa>1</upa>
<pnr>0299801750</pnr>;Power Management LT1175IS8-5;<upa>3</upa>
<pnr>0233201780</pnr>;Amplificator LT1498CS8;<upa>4</upa>';
$subst = "<kwd>$1</kwd><adt>$2</adt>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;