$re = '/([0-9A-Za-z_\.-]+)@([]0-9A-Za-z_\-]+)\.([a-z]{2,9})/m';
$str = 'a@b.com
a@b.cz
a@b.org
a@b.pl
fredy.crueger@elm-street.com
fredy_crueger@elm-street.com
fredy-crueger@elm-street.com
fredy.crueger@.elm-street.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);