# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:.*\r?\n){2}.*random data.*"
test_str = ("Line 1\n"
"Line 2\n"
"Line 1 with random data.\n"
"Line 4\n"
"Line 5\n"
"Line 2 with random data.\n"
"Line 7\n"
"Line 8\n"
"Line 9\n"
"Line 10\n"
"Line with random data.Line with random data.")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.