// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((\+?234)|0)([89]((0[0-9])|(1[0-9]))|([79]0[1-9]))[0-9]{7}$").unwrap();
let string = "08064443187";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}