# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d+:\D{8}\d{2}"
test_str = ("1:nlcbjduy14 <- I want regex to find this one \n"
"2:Peoples123 <- I don't want regex to find this one, as it has 3 digits.\n"
"3:sqourzyr17 <- I want regex to find this one\n"
"4:rdmaszgr94 <- I want regex to find this one\n"
"5:tnwiudic22 <- I want regex to find this one\n"
"6:zfcxmkrs21 <- I want regex to find this one\n"
"7:xrwhsgno55 <- I want regex to find this one\n"
"8:modtwtrr06 <- I want regex to find this one\n"
"9:People123 <- I don't want regex to find this one, as it is isn't 10 chars long and it consists of 3 digits.\n"
"10:aetmyqqh52 <- I want regex to find this one\n"
"11:Howtocodelikeapro12 <- I don't want regex to find this one, as it is isn't 10 chars long\n"
"12:netphvib58 <- I want regex to find this one\n"
"13:uwyiqhoj29 <- I want regex to find this one\n"
"14:RegexJustiIsntDoingItForMe\n"
"15:qyeiaecj27 <- I want regex to find this one\n"
"16:buttercake <- I don't want regex to find this one, as it doesn't end with 2 digits.\n"
"17:bcyiyjdm23 <- I want regex to find this one\n"
"18:Differings <- I don't want regex to find this one, as it doesn't end with 2 digits.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.