# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\h+constraint\h+[^,]*)(,?)/$2 --$1/gm;t' <<< "This is with something extra constraint xhiho,
This is without something extra constraint hfdlh"