import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\h+constraint\\h+[^,]*)(,?)";
final String string = "This is with something extra constraint xhiho,\n\n"
+ "This is without something extra constraint hfdlh";
final String subst = "$2 --$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}