re = /(\h+constraint\h+[^,]*)(,?)/m
str = 'This is with something extra constraint xhiho,
This is without something extra constraint hfdlh'
subst = '$2 --$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result