using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[1-9]\d*\.\d+\.\d+(?:-[a-zA-Z0-9]+)?$";
string input = @"1.2.40
1.0.0-SNAPSHOT
2.0.45-RC
3.10.0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}