import Foundation
let pattern = #"[\\\/:*?\x22<>|]"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
\Te\st/
Tes*t1
"Test*2
Te<st:3
Te>st?4
Te"st>5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)