import re
regex = re.compile(r"(([\w\s\d]+\s)(is the|is a|are the|are a|was)\s([\w\d\s\[\]\)\(,']+))")
test_str = "Hendrik Weber (born 1975), better known as Pantha du Prince, Panthel and Glühen 4 is a German producer, composer and conceptual artist for Electro, Techno, House, Minimal and Noise affiliated with Hamburg's Dial music label[1][2] and British label Rough Trade.[3]"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")