#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i){IF:(.*?)}[\s]*?(.*?)[\s]*?{ELSE}[\s]*?(.*?)[\s]*?{ENDIF}"
Local $sString = "// Does NOT Work with html tags// " & @CRLF & _
"" & @CRLF & _
" {IF:(!isset($_SESSION['loggedin']))}" & @CRLF & _
"" & @CRLF & _
" <div>" & @CRLF & _
" <p>This code no longer works</p>" & @CRLF & _
" <p>Remove this div and everything will work.</p>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" {ELSE}" & @CRLF & _
"" & @CRLF & _
" Bleh" & @CRLF & _
"" & @CRLF & _
" {ENDIF}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")