const regex = /{IF:(.*?)}[\s]*?(.*?)[\s]*?{ELSE}[\s]*?(.*?)[\s]*?{ENDIF}/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{IF:(.*?)}[\\s]*?(.*?)[\\s]*?{ELSE}[\\s]*?(.*?)[\\s]*?{ENDIF}', 'i')
const str = `// Does NOT Work with html tags//
{IF:(!isset(\$_SESSION['loggedin']))}
<div>
<p>This code no longer works</p>
<p>Remove this div and everything will work.</p>
</div>
{ELSE}
Bleh
{ENDIF}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}