// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i){IF:(.*?)}[\s]*?(.*?)[\s]*?{ELSE}[\s]*?(.*?)[\s]*?{ENDIF}").unwrap();
let string = "// Does NOT Work with html tags//
{IF:(!isset($_SESSION['loggedin']))}
<div>
<p>This code no longer works</p>
<p>Remove this div and everything will work.</p>
</div>
{ELSE}
Bleh
{ENDIF}
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}