re = /^\w+((\-?| ?)\w+)? [a-bA-B] (\d{9}|((\d{3} ){2}\d{3}))$/m
str = 'CLERMONTFERRAND B 321 654 897
Paris A 321 546 987
Test Rien B 645213564
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end