$re = '/(["\']).*\1(?![^\s])/';
$str = '"a\'b"
"ab"
\'ffg\' "hhh"
""
\'\'
"\'"
\'acd" \'gf
"Don\'t forget the @"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);