import Foundation
let pattern = #"\b[A-Z].*?\d{1,2}\.\d{1,2}\.\d{2,4}(?=\s+[A-Z]|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
N678 à p. du 11.6.23 C+23.6.23 N−14.,24.7.23
N678 N−12.,13.12.22,18.,19.,31.1.,9.2.,7. au 10.,13. au 17.,20.,21.,22.,28.
au 31.3.,6.,13.,19.,20.4.,5.,8.5.23
N68 du 12.6. au 3.9.23 C+23.6.,15.8.23 N-18.,25.6.,2.,17. au 21.,23. au 28.,31.7.,3.,4.,7.,8.,9.,27.8.23
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)