$re = '/(".*?")|((?<group>\b([A-z*]+))-)/m';
$str = 'Jean-Pierre bought "blue-green-red" product-2345 and other blue-red stuff. "a-a"';
$subst = "${group} $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;