$re = '/\b(r(a|à|á|â|ä|æ|ã|å|ā)p(e|3|è|é|ê|ë|ē|ė|ę))\s*/im';
$str = 'rape grape g rape ra pe rapes';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);