const regex = /hspace="10">(.+)</gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('hspace="10">(.+)<', 'gm')
const str = `<div class="qselections">
<img src="/images/tickbox.gif" alt="" hspace="10">doing
<img src="///images/tickedbox.gif" alt="" hspace="10">be
<img src="//images/tickbox.gif" alt="" hspace="10">been
<img src="//images/tickbox.gif" alt="" hspace="10">by<br>
<img src="//images/tickbox.gif" alt="" hspace="10">out<br>
<img src="//images/tickedbox.gif" alt="" hspace="10">over<br>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}