#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "service\-(?P<serviceName>[a-zA-Z]+[a-zA-Z-]+[a-zA-Z]+)\-v(?P<versionMajor>[0-9]+)\.(?P<versionMinor>[0-9]+)\.(?P<versionPatch>[0-9]+)(?:\-(?P<versionType>alpha|beta|rc)(?:\.(?P<versionTypeNumber>[0-9]+)))?\.(?P<fileExt>gtw)"
Local $sString = "service-bad-v1.0.0-ddd.1.gtw" & @CRLF & _
"service-bad-v.0.0.gtw" & @CRLF & _
"service-bad-v1..0.gtw" & @CRLF & _
"service-bad-1.0.0.gtw" & @CRLF & _
"service-bad-cool--v1.0.0-alpha.1.gtw" & @CRLF & _
"service--bad-cool-v1.0.0-alpha.1.gtw" & @CRLF & _
"service-user-v1.0.0" & @CRLF & _
"service-user-v1.0.0-alpha.1" & @CRLF & _
"service-channel-cool-v1.0.0-alpha.1" & @CRLF & _
"service-user-v1.0.0.gtw" & @CRLF & _
"service-user-v1.0.0-alpha.1.gtw" & @CRLF & _
"service-channel-cool-v1.0.0-alpha.1.gtw"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")