import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "service\\-(?P<serviceName>[a-zA-Z]+[a-zA-Z-]+[a-zA-Z]+)\\-v(?P<versionMajor>[0-9]+)\\.(?P<versionMinor>[0-9]+)\\.(?P<versionPatch>[0-9]+)(?:\\-(?P<versionType>alpha|beta|rc)(?:\\.(?P<versionTypeNumber>[0-9]+)))?\\.(?P<fileExt>gtw)";
final String string = "service-bad-v1.0.0-ddd.1.gtw\n"
+ "service-bad-v.0.0.gtw\n"
+ "service-bad-v1..0.gtw\n"
+ "service-bad-1.0.0.gtw\n"
+ "service-bad-cool--v1.0.0-alpha.1.gtw\n"
+ "service--bad-cool-v1.0.0-alpha.1.gtw\n"
+ "service-user-v1.0.0\n"
+ "service-user-v1.0.0-alpha.1\n"
+ "service-channel-cool-v1.0.0-alpha.1\n"
+ "service-user-v1.0.0.gtw\n"
+ "service-user-v1.0.0-alpha.1.gtw\n"
+ "service-channel-cool-v1.0.0-alpha.1.gtw";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}