const regex = new RegExp('service\\-(?P<serviceName>[a-zA-Z]+[a-zA-Z-]+[a-zA-Z]+)\\-v(?P<versionMajor>[0-9]+)\\.(?P<versionMinor>[0-9]+)\\.(?P<versionPatch>[0-9]+)(?:\\-(?P<versionType>alpha|beta|rc)(?:\\.(?P<versionTypeNumber>[0-9]+)))?\\.(?P<fileExt>gtw)', 'g')
const str = `service-bad-v1.0.0-ddd.1.gtw
service-bad-v.0.0.gtw
service-bad-v1..0.gtw
service-bad-1.0.0.gtw
service-bad-cool--v1.0.0-alpha.1.gtw
service--bad-cool-v1.0.0-alpha.1.gtw
service-user-v1.0.0
service-user-v1.0.0-alpha.1
service-channel-cool-v1.0.0-alpha.1
service-user-v1.0.0.gtw
service-user-v1.0.0-alpha.1.gtw
service-channel-cool-v1.0.0-alpha.1.gtw`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}