use strict;
my $str = 'service-bad-v1.0.0-ddd.1.gtw
service-bad-v.0.0.gtw
service-bad-v1..0.gtw
service-bad-1.0.0.gtw
service-bad-cool--v1.0.0-alpha.1.gtw
service--bad-cool-v1.0.0-alpha.1.gtw
service-user-v1.0.0
service-user-v1.0.0-alpha.1
service-channel-cool-v1.0.0-alpha.1
service-user-v1.0.0.gtw
service-user-v1.0.0-alpha.1.gtw
service-channel-cool-v1.0.0-alpha.1.gtw';
my $regex = qr`service\-(?P<serviceName>[a-zA-Z]+[a-zA-Z-]+[a-zA-Z]+)\-v(?P<versionMajor>[0-9]+)\.(?P<versionMinor>[0-9]+)\.(?P<versionPatch>[0-9]+)(?:\-(?P<versionType>alpha|beta|rc)(?:\.(?P<versionTypeNumber>[0-9]+)))?\.(?P<fileExt>gtw)`p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}