#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\w+['’])?\w+(?:-(?:\w+['’])?\w+)+|\w+['’]\w+"
Local $sString = "O'Hara-O’Mara" & @CRLF & _
"O'Hara" & @CRLF & _
"O’Mara" & @CRLF & _
"Kara" & @CRLF & _
"" & @CRLF & _
"1234" & @CRLF & _
"abc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")