package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\w+['’])?\w+(?:-(?:\w+['’])?\w+)+|\w+['’]\w+`)
var str = `O'Hara-O’Mara
O'Hara
O’Mara
Kara
1234
abc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}