package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[A-Z][a-z]*\b`)
var str = `Meet Kara Denvers and Barry Allen.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}