const regex = /((?!\[)[\d\-]+(?=\]))|((?!\[){{[\w-_]*}}=[\d-]+(?=\]))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?!\\[)[\\d\\-]+(?=\\]))|((?!\\[){{[\\w-_]*}}=[\\d-]+(?=\\]))', 'g')
const str = `Date format: [2017-10-27] or [{{variable-name}}=2017-10-27]
//match the date format [YYYY-MM-DD] or [{{variable-name}}=YYYY-MM-DD] for datepicker, but filter out "Square Brackets[]" at the same time? `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}