import Foundation
let pattern = #"^([a-z]+)(?:([A-Z]{1})([a-z]+))+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
myjfgfgffhVarBaThisVinoth
myVar
MYVAR
my-var
my.var
Myvar
My var
my var
Myvar
myvar
my Var
myVar
myVAR
myVARandV
my_var
myVarAndV
myAndVar
myV_ar
my_Var
my*Var
myV*ar
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)