package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\b\d{5})((##DEU-Akten|[PZ] ?DEU)|(##Schutzerstreckungen|W ?WOS)|(##Widerspruch|[BRK] ?([A-Z]{2}|[MZ][123]|R1|T[12])([-_]?([A-Z]{2}|[MZ][123]|R1|T[12]))?(-?\d+)?(\.?\d+)?)|(##mitLand|([PZGDWSEL]|[NVYTXCUAK]) ?((((HK-?CN)|(([A-Z]{2}|[MZ][123]|R1|T[12])(-?EP|-?EM|-?AP|-?OA)?))(-?WO|-?W\d+?)?|S))(-?\d+)?)|((##ohneLand|[NVYTXCUAK])(-?\d+)?))`)
var str = `62877K`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}