#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?<!\$|->)\w+\[]"
Local $sString = "/** @var string[] */" & @CRLF & _
"/** @return string[] */" & @CRLF & _
"* @param Company[]|null $companies" & @CRLF & _
"" & @CRLF & _
"$icons[] = static::getIconDetailsFromLink($link);" & @CRLF & _
"$this->properties[] = $property;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")