$re = '/^[A-Z][\w\s]+[?.!]$/m';
$str = 'This sentence is correct.
this sentence does not start with capital.
This sentence is not correct';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);