const regex = /^(.+)\bby\b(.+)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.+)\\bby\\b(.+)$', 'g')
const str = `Death by Blackhole by Tyson`;
const subst = `$1: $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);