re = /^(.+)\bby\b(.+)$/
str = 'Death by Blackhole by Tyson'
subst = '$1: $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result