import Foundation
let pattern = #"^(.+)\bby\b(.+)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Death by Blackhole by Tyson"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1: $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)