using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([^<>\/\s]+)[^<>]*>";
string substitution = @"<\1>";
string input = @"<li class=""ulchildlink"" data-hd-product=""SSEPEK_11.0.0"" data-hd-operatingsystem=""zOS""><span class=""ulchildlinktext""><a href=""../../src/tpc/n007.html?view=kc"">-007</a></span><br>
STATEMENT CONTAINS THE ILLEGAL CHARACTER <var class=""keyword varname ibm-item-note-alternate"">invalid-character</var></li>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}