// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<([^<>\/\s]+)[^<>]*>").unwrap();
let string = "<li class=\"ulchildlink\" data-hd-product=\"SSEPEK_11.0.0\" data-hd-operatingsystem=\"zOS\"><span class=\"ulchildlinktext\"><a href=\"../../src/tpc/n007.html?view=kc\">-007</a></span><br>
STATEMENT CONTAINS THE ILLEGAL CHARACTER <var class=\"keyword varname ibm-item-note-alternate\">invalid-character</var></li>";
let substitution = "<\\1>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}