$re = '/^\s*\w+(?:\s+\w+)*?(?:\s*<\w+>)?\s+(\w+)(?=\s*[=;])/m';
$str = 'import java.io.File;
import java.io.IOException;
import java.util.ArrayList;
import java.util.List;
private final String COMMENTS = "test";
private final String VARIABLE_NAME_REGEX="(\\w*)<?>?\\s*=(?=(?:[^"]|"[^"]*["])*$)";
String test="test";
String test222;
String includeThisAlso ;
List <String> arr;
List <String> list=null;
private final String COMMENTS = "test";
private List<String> test;
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);