import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\d{4})\\/(\\d{2,4})(?:\\/(\\w{2}))?(?!\\S)";
final String string = "which seems to work properly, but I want to avoid the cases in which for example: I have a string \"2020/2000/WEEEE\" and it matches it.\n\n"
+ "Other wrong example that it matches: \"IEN/BSK-2020/143999\" .\n\n"
+ "4444/1234/en";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}