#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+\.[A-Za-z]{2,6}\b"
Local $sString = "2536320:GlorySon:Maximono@web.de:84.153.217.22:a6b585f1ba0461ae2ae30cca72c5d9e0:J3!'Zau&@s`IlB%\\gDhqk>K8~W,QSP" & @CRLF & _
"470957:Redemptor:got_lowrider@hotmail.com:24.77.161.226:daa4f847e4c2eef69d3fd30bab8c8ae2:]2a" & @CRLF & _
"49114:Lavis:Albert_Rene@voila.fr:82.236.195.211:8db988462a0c5403a4c2afc2c4e5f87d:/<I"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")